AEM Not Saving Changes

6 posts / 0 new
Last post
Plantagenet
Plantagenet's picture
AEM Not Saving Changes

After having spent over two long hours laboriously updating eBook information from the web, I closed AEM and shut down my PC.
Later in the day, having restarted my PC, I opened AEM to find that none of the changes that I had made earlier had been saved.
I couldn't believe it!
So , as a bit of a trial, I updated just one book, I then closed AEM, re-opened it and happily the change had been saved.
Great I thought, just a one-off glitch, but to make absolutely sure, I updated another book, then closed and reopened AEM and guess what? The changes had not been saved.
This is a total deal breaker for me because if I can't depend on AEM saving the changes, and as the programme stands I obviously can't, then Alfa eBooks Manager is no good to me.
Can you please suggest a solution to this problem before I give up with Alfa eBooks Manager altogether?
Peter.

admin
admin's picture

Peter, please check is that are certain books updated from the certain site that are not saved, or it's a random process?
Is the book data saved when you close a Book Card?
Until now we have no such complaints that book data is not saved

Plantagenet
Plantagenet's picture

Okay, well as my native language is English I have set Alfa eBooks Manager to search on the following sites:

Amazon, USA
Amazon. Canada
Amazon, UK
Barnes and Noble, USA
Google Library, USA

I have tried different books with each of these different sites in turn.
When I click Update and then close the Library Card, the information appears to be saved, ie a thumb-nail has been added, book description and details have been added, etc.
If I then close and re-open AEM, the information, thumb-nail, description and details have all disappeared.
This happens more often than not, but occasionaly AEM does indeed save the information when the programme is re-opened.
The trouble is I can't depend on it doing that, so for the time being at least, I have gone back to using Calibre which is a disappointment to me as I had high hopes of AEM.

I am using Windows 7 and I am using a USB 8Gb thumb-drive as storage for my books and AEM Library.
I have checked the plug-ins for updates and they are all up to date currently Version 5.1.0.21486
My version of AEM Pro is 5.1.0.2
Up until yesterday (16th August) I didn't have a problem.

Do you have any suggestions?
Thanks, Peter.

Plantagenet
Plantagenet's picture

Well do you have any suggestions?

admin
admin's picture

Peter, could you copy the database from USB drive to PC and check if the data is saved?

Plantagenet
Plantagenet's picture

Okay, I've done as you suggested and I now have AEM's DataBase saved to the 'C' Drive of my PC.
I've tried updating and saving information on a couple of books and all seems OK! Phew!! :)
I'll try more books and get back to you tomorrow (Tuesday) on how things are going, but for now (fingers crossed) all seems good.
Thanks again, Peter.